After update to 1.9.2 the LDAP is not working anymore in docker

My version of HedgeDoc is: docker image quay.io/hedgedoc/hedgedoc:1.9.2-alpine

I updated HedgeDoc from 1.7.2 (I think…) to 1.9.2 and after the update the LDAP connection is not working anymore.

With all of the versions between 1.7.2 and 1.9.2 I get the problem that the CSS Design of the HedgeDoc site is not correct.

The LDAP server is a FreeIPA server and the LDAP connection worked fine previously with the following configuration:

  - CMD_LDAP_URL=ldap://ldap.intra.company.com
  - CMD_LDAP_BINDDN=uid=tu_hedgedoc,cn=users,cn=accounts,dc=intra,dc=company,dc=com
  - CMD_LDAP_BINDCREDENTIALS=abcdefghijklmnopqrstuvwxyz123456
  - CMD_LDAP_SEARCHBASE=cn=users,cn=accounts,dc=intra,dc=company,dc=com
  - CMD_LDAP_SEARCHFILTER=(&(objectClass=person)(uid={{username}}))
  - CMD_LDAP_SEARCHATTRIBUTES=uid,mail,displayName
  - CMD_LDAP_USERNAMEFIELD=displayName
  - CMD_LDAP_USERIDFIELD=uid
  - CMD_LDAP_PROVIDERNAME="FreeIPA Authentication"

I tried already to add the internal root certificate and added the following line:

  - CMD_LDAP_TLS_CA=/etc/ssl/certs/Internal_Root_CA.crt

After starting the docker container I see the following lines in the logs of the docker container and I’m wondering, maybe they have something to do with the problem?

app_1       | /bin/sh: git: not found
app_1       | 2021-12-06T15:19:45.368Z warn:    Session secret not set. Using random generated one. Please set `sessionSecret` in your config.json file. All users will be logged out.
app_1       | 2021-12-06T15:19:46.189Z info:    All migrations performed successfully
app_1       | 2021-12-06T15:19:46.207Z info:    HTTP Server listening at 0.0.0.0:3000
app_1       | 2021-12-06T15:19:47.137Z info:    127.0.0.1 - - [06/Dec/2021:15:19:47 +0000] "GET /status HTTP/1.1" 200 268 "-" "node-fetch/1.0 (+https://github.com/bitinn/node-fetch)"

The line containing “node-fetch” will appear every 5 seconds in the docker log.

I would be very grateful if someone has an idea, what the problem is in this situation or how to solve it. Thanks everyone.

With all of the versions between 1.7.2 and 1.9.2 I get the problem that the CSS Design of the HedgeDoc site is not correct.

Have a look at FAQ - HedgeDoc

Regarding your logs:

  • Missing git is expected in the container
  • You should set a session secret, otherwise (as the log says) all users will be logged out on each container restart. You can use the CMD_SESSION_SECRET environment variable.
  • The node-fetch requests are caused by the container health-check.

How does “the LDAP connection is not working anymore” manifest? Does the login not work? Please post the server logs of a login attempt if this is the case.

I think CMD_PROTOCOL_USESSL was the culprit. Changing this value solved the problem. I although added the CMD_SESSION_SECRET and now it runs without problems. Thank you!