Completely suspect behaviour user disappeared


I noticed a really suspect behaviour with my HedgeDoc 1.8.1 (OS Ubuntu 20.04). I updated the new version a couple of weeks without any problems afterwards I was able to login many many times and I was able to work without problems for weeks.

Now I noticed that I am not able to login with the user credentials I allways use. I verified the credentials multiple times with my password safe.

Afterwards I tried to reset the password using the manage_users app but I receive the error message that my e-mail does not exists.

root@cubeblack:~# docker ps
59e72ba002d5 “/usr/local/bin/dock…” 5 weeks ago Up 25 hours>3000/tcp root_app_1
b924900f24d8 postgres:9.6-alpine “docker-entrypoint.s…” 5 weeks ago Up 25 hours 5432/tcp root_database_1
b34b1c4d4dff postgres:9.6-alpine “docker-entrypoint.s…” 5 months ago Up 25 hours 5432/tcp hedgedoc-container_database_1

root@cubeblack:~# docker exec -it 59e72ba002d5 bash

root@59e72ba002d5:/hedgedoc# ./bin/manage_users --reset
User with e-mail does not exist, cannot reset

Does anyone know how this can happen ?
More important for me is how can I export my documents ?


If I see this correct, you have two databases. One called hedgedoc-container_database_1 and one called root_database_1. If I would need to guess, I would say, that your account might got lost when you switched from one database to the other.

Hello sheogorath,

thank you for your feedback.

It might be but it would be really suspect because after I updated hedgedoc from a previous version (around 5 weeks ago) I did’t log in to the cli. Maybe the Ubuntu Autoupdate did something but I did’t login.

However, do you have an idea how I could access the markdown files at least to export the files ?

I tried to stop and rm container id b924900f24d8 and after restoring a backup I stopped and rm container id b34b1c4d4dff because I hoped that the correct database would be used. Unfortunately in both cases I received a 502 error.