Help with Emoji error

My version of CodiMD is: 1.7.2

What I expected to happen:

1.When I upload a photo it should appear.
2.When I add an Emoji it should appear
3. Everything else works like a charm
What actually happened:

  1. Image not appears, nothing happen
  2. The amoji appers, but a second later the editor desappears and 404Error page loads. I think is something with database Lang, but I ve tried to modify the yml file adding UTF-8mb4 with no success.

I already tried:

version: “2”
services:
mariadb:
image: ghcr.io/linuxserver/mariadb:latest
container_name: hedgedoc_mariadb
restart: always
volumes:
- /volume1/docker/mariadb_hedgedoc:/config
environment:
- MYSQL_ROOT_PASSWORD=Mypass
- MYSQL_DATABASE=hedgedoc
- MYSQL_USER=hedgedoc
- MYSQL_PASSWORD=Mypass
- PGID=1000
- PUID=1000
- LANGUAGE=es_ES.UTF-8mb4
- LANG=es_ES.UTF-8mb4
- TZ=Europe/Madrid
hedgedoc:
image: ghcr.io/linuxserver/hedgedoc:latest
container_name: hedgedoc
restart: always
depends_on:
- mariadb
volumes:
- /volume1/docker/hedgedoc/config:/config
environment:
- DB_HOST=mariadb
- DB_USER=hedgedoc
- DB_PASS=Mypass
- DB_NAME=hedgedoc
- DB_PORT=3306
- PGID=1000
- PUID=1000
- TZ=Europe/Madrid
ports:
- “3000:3000”

This dockers are running on a Synology NAS, and installed with portainer.
Any help would be appreciated

Hello @magefesa,

welcome to the community.

  1. Image not appears, nothing happen

Could you have a look at the Console in your Browser and the HedgeDoc log? A total silent failure seems very unlikely.

  1. The amoji appers, but a second later the editor desappears and 404Error page loads. I think is something with database Lang, but I ve tried to modify the yml file adding UTF-8mb4 with no success.

Could elaborate a bit more what you did with UTF-8mb4? What did you add? And what did you do then? Did you recreate the DB, because iirc you need to do that to get a database with UTF-8mb4 or you need to change this setting in your DB and reencode the contents. In any case a simple change in the .yml file should not help.

Did you write this docker-compose file yourself or did you get it from somewhere.

Greetings
DerMolly

I m Sorry !

  1. Here is the log:

  1. I ve googled a few and seen that this error (emoji insertion), is usually due to encoding database. I ve added es_ES.UTF-8mb4 To solve it, logically removing database files and recreating again the docker compose file.

This file is from: Linuxserver.io

No ideas ? Somebody could note how to install using yml file ?

Thanks

Hey magefesa,

  1. The file extension of your file does not match what the files contents are. This is new feature we included recently to circumvent a rather serious bug. If your file is an .jpeg file the bug is known and a fix is already in the making. In the mean time uploading a the same file with a .jpg extension should do the trick.
  2. I’m not to sure what the problem could be there. Our own docker installation uses postgres instead of mysql, maybe you want to have a look at that? https://github.com/hedgedoc/container/

Greetings
DerMolly

Thanks for your reply. I ll try and I ll keep you informed !
Thanks again for. your detailed answer !