I can't upload local pictures

My version of HedgeDoc is: <1.7.2>

What I expected to happen:
I want to upload local pictures

What actually happened:
I failed to upload the local picture in the document. How should I modify the configuration file
thank you to everyone

I already tried:

I have tried modifying default.js,lutim:{url:‘myIP:3000’},but still can’t upload
I don’t understand what ‘‘filesystem’’ means
I was not found in the https://docs.hedgedoc.org/configuration/#hedgedoc-basics about the configuration of local image upload
Do you have a configuration for uploading images from the client to the server?

Hi and welcome to the HedgeDoc community forum!

First, you don’t need to change any JavaScript code files like default.js in order to configure your instance.
Depending on how you set up your HedgeDoc instance there are two ways how to configure it: In case of a docker setup, you might want to set some environment variables, otherwise you could run bin/setup from the root of your installation and afterwards tweak the config.json file.

The “filesystem” upload type means, that user uploads are stored to and served from a local directory on your server. You just need to set the CMD_DOMAIN environment variable or the domain config.json key.

The lutim upload is only intended for use with the lutim server software.

I hope, this helps you to get started.

thank you very much for your help,I tried to run the ./bin/setup command and it worked
I modified the ‘domain’ parameter in config.json, but it made my website inaccessible, so I can only restore it. Could you please tell me how I can modify it to upload pictures
I’m sorry to bother you, but can you help me again?

Oh, that’s an easy one: don’t put a port in the domain field. There is a separate setting that handles the ports.

Thank you very much for your help.I have deleted the port and used localhost, but I still cannot upload

Do you have a reverse proxy in front of your HedgeDoc instance?
If so, be sure to read https://docs.hedgedoc.org/guides/reverse-proxy/