InternalOAuthError: Failed to obtain access token github

My version of HedgeDoc is: <1.9.9>

What I expected to happen:

I am trying to use Oauth from github
What actually happened:

InternalOAuthError: Failed to obtain access token
    at OAuth2Strategy._createOAuthError (/hedgedoc/node_modules/passport-oauth2/lib/strategy.js:423:17)
    at /hedgedoc/node_modules/passport-oauth2/lib/strategy.js:177:45
    at /hedgedoc/node_modules/passport-github/lib/strategy.js:75:25
    at /hedgedoc/node_modules/oauth/lib/oauth2.js:191:18
    at ClientRequest.<anonymous> (/hedgedoc/node_modules/oauth/lib/oauth2.js:162:5)
    at ClientRequest.emit (node:events:514:28)
    at TLSSocket.socketErrorListener (node:_http_client:495:9)
    at TLSSocket.emit (node:events:514:28)
    at emitErrorNT (node:internal/streams/destroy:151:8)
    at emitErrorCloseNT (node:internal/streams/destroy:116:3)
    at process.processTicksAndRejections (node:internal/process/task_queues:82:21)

I already tried:

I have everything inside a raspberry pi 5, managed with portainer. I use cloudflare tunnel to tunnel the service. A few days ago my internet connection dropped and disconfigured my IP, the pihole with the DNS server.
Yesterday I was able to re-establish it but today when I tried to take notes for the university I realized that it didn’t let me auth me with github.
I changed the secret, I changed the tag to latest container.
I don’t know what it could be.