Mermaid graph and slide mode

My version of HedgeDoc is: I use de docker version quay.io/hedgedoc/hedgedoc:1.7.1

What I expected to happen:

That the mermaid graphic occupies the maximum size of the slide

What actually happened:

In the slide mode my mermaid graph comes small and unconfigured:

Moderator’s note: I removed the link for a fear of vandalism.
~DerMolly

I already tried:

I tried to use style inside de mermaid syntax and in the style tag, but nothing happening

Thanks for your attention

You could try to include a general style tag in your note and change the behaviour for the image this way, but I’m not sure there is any other short term help.

Hi @DerMolly thaks, for your help.
I’m think that the mermaid webpack doesn’t allow me to change the style with the tag, I looked in the mermaid documentation and even found the variables that need to be changed, but this inside hedgedoc seemed like an implementation issue to me.

You can try these options, which should result in the slide content using the full width of the page:

slideOptions:
  width: "100%"
  height: "100%"
  margin: 0
  minScale: 1
  maxScale: 1
1 Like

Hi @davidmehren Thank you for taking the time to reply.
I tried these settings, laterally the graph took up all the space it could, but vertically it stayed the same and still small.
Where can I find the references to these variables for slideoptions?