OAuth2 Gravatar Avatars not showing up

My version of HedgeDoc is: 1.9.2/latest

I just noticed that the CodiMD community had largely moved to HedgeDoc, and so I just decided to migrate. Everything worked fine, except that our avatars no longer appear.
I expected that my avatars would still be visible, as libravatar falls back to gravatar. When I look up my email on Libravatar, the correct avatar shows up for MD5. Instead, the default avatar was used in HedgeDoc.

The only possible issue I can think of is that I am still using postgress:11.6-alpine, though I’m not sure why that would cause an issue and I did not see any errors with debug mode enabled.

Edit: The same thing happens with a fresh container and postgres 13.4-alpine.
Here are my associated environment variables that work with CodiMD:

  • CMD_OAUTH2_SCOPE=openid email profile


This sounds odd and definitely should still work.

Can you check the browser console for errors on any page where an avatar should appear?

When I checked, I did not see any errors. I was using Keycloak as my auth provider.
I also tried visiting on different browsers and in incognito mode, to the same results.

There were no errors in the container console or any logs as far as I could see either.

If need be, I could provide an email which has the issue.

If need be, I could provide an email which has the issue.

That would be great. Could you send that as a private message to @mrdrogdrog or me?
We’d like to reproduce that issue.

1 Like

We were able to reproduce and fix this issue.
The fix will be released altogether with the next bugfix release.