Struggling to run hedgedoc on ubuntu 22+

My version of HedgeDoc is: latest github version (forked today)

What I expected to happen:

Want to run the program and I followed this guide:

But i’m having issue while running thoses commands on cmd:
yarn build run
yarn build
yarn run

What actually happened:
I can’t send pictures since i’m “new user”

    throw err;

Error: Cannot find module 'worker_threads'
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:636:15)
    at Function.Module._load (internal/modules/cjs/loader.js:562:25)
    at Module.require (internal/modules/cjs/loader.js:692:17)
    at require (internal/modules/cjs/helpers.js:25:18)
    at /home/ggh/Bureau/LogLibre/hedgedoc/.yarn/releases/yarn-3.4.1.cjs:423:2576
    at Object.<anonymous> (/home/ggh/Bureau/LogLibre/hedgedoc/.yarn/releases/yarn-3.4.1.cjs:743:8770)
    at Module._compile (internal/modules/cjs/loader.js:778:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:789:10)
    at Module.load (internal/modules/cjs/loader.js:653:32)
    at tryModuleLoad (internal/modules/cjs/loader.js:593:12)

I already tried:

everything i could. lol

it looks like you forked the develop branch, which contains HedgeDoc 2.
As far as I am aware, HedgeDoc 2 is not yet ready for actual use.
You probably want to deploy HedgeDoc 1, which you can find in the master branch.


Hello thank you for the answer , I just forked the master branch right now and I tried to launch hegedoc correctly hopefully I can now run “yarn run build” and “node app.js” correctly however there seems to be not any graphic interface so I think im doing something bad do you know how to do it properly?

edited – nevermind just saw that it was on localhost:3000 by default