Text only, no graphic

My version of HedgeDoc is: ghcr.io/linuxserver/hedgedoc:version-1.8.2

What I expected to happen:
When I go to http://192.168.1.133:3003 I only see text.

What actually happened:
I would have expected to see a web page with graphical content.

I already tried:
I have tried to change the CMD_DOMAIN from localhost to 192.168.1.133.
The OS is Unraid, and my docker command is the following: docker create --name=‘hedgedoc’ --net=‘docker-net’ -e TZ=“Europe/Paris” -e HOST_OS=“Unraid” -e ‘DB_HOST’=‘192.168.1.133’ -e ‘DB_PORT’=‘3306’ -e ‘DB_USER’=‘hedgedoc’ -e ‘DB_PASS’=‘MY_PASSWORD’ -e ‘DB_NAME’=‘hedgedoc’ -e ‘CMD_DOMAIN’=‘192.168.1.133’ -e ‘CMD_LOGLEVEL’=‘verbose’ -e ‘PUID’=‘99’ -e ‘PGID’=‘100’ -e ‘UMASK’=‘022’ -p ‘3003:3000/tcp’ -v ‘/mnt/user/appdata/hedgedoc’:’/config’:‘rw’ ‘ghcr.io/linuxserver/hedgedoc

My config.json contains:
{
“use_env_variable”: “CMD_DB_URL”
}

Hey @Jorgensen,

welcome to the forum.

Could you have a look at network tab, in your browser and tell us what it shows as an error with the css and image files? I think this could benefit in solving this problem.

Greetings
DerMolly

Thanks a lot, @DerMolly

Please note, that I did try to change some networks setting just now. Thus, HedgeDoc is now at 192.168.87.133:3000 and not 192.168.1.133:3003. The outcome is the same.
Anyway, the network tab shows this

Am I missing a port setting somewhere? E.g. if I press “intro” in the top left corner I’m redirected to 192.168.87.133/login. If I manually add :3000 I see a hegdedoc login page, text only though.

If you run with a custom port, you need to set CMD_URL_ADDPORT to true. See also the docs.

Thanks @davidmehren, it works!!!
So a “custom port” is any port not being 80 or 443?

Exactly. Ports 80 and 443 are the default ports for HTTP and HTTPS respectively and can be omitted. Everything else has to be added to the URL and therefore configured.

Hi again.

Due to conflicting port allocations, I would like to access HD on port 3002 (or any other free port) instead of 3000. However, when I run the below command, I face my original problem, with only text being shown.

docker create --name=‘hedgedoc’ --net=‘docker-net’ -e TZ=“Europe/Paris” -e HOST_OS=“Unraid” -e ‘DB_HOST’=‘192.168.87.133’ -e ‘DB_PORT’=‘3306’ -e ‘DB_USER’=MY_USERNAME -e ‘DB_PASS’=MY_SECRET_PASSWORD -e ‘DB_NAME’=‘hedgedoc’ -e ‘CMD_DOMAIN’=‘192.168.87.133’ -e ‘CMD_LOGLEVEL’=‘verbose’ -e ‘CMD_URL_ADDPORT’=‘true’ -e ‘CMD_EMAIL’=‘true’ -e ‘CMD_ALLOW_ANONYMOUS’=‘false’ -e ‘CMD_ALLOW_EMAIL_REGISTER’=‘false’ -e ‘CMD_PORT’=‘3000’ -e ‘PUID’=‘99’ -e ‘PGID’=‘100’ -e ‘UMASK’=‘022’ -p ‘3002:3000/tcp’ -v ‘/mnt/user/appdata/hedgedoc’:’/config’:‘rw’ ‘ghcr.io/linuxserver/hedgedoc

I’ve tried with CMD_PORT = 3000 and 3002, but neither works. I’ve looked in the documentation, but can’t find any clues how to fix it.

I hope you can help fix this issue (again).

Best Regards,
Jorgensen