Weird node-fetch behaviour

My version of HedgeDoc is: 1.9.0

What I expected to happen:

No regular internal requests (approx. every 5 seconds) to /status route

What actually happened:

As stated above, every 5 seconds an internal request to the /status route is made:
2021-10-04T10:17:27.825Z info: 127.0.0.1 - - [04/Oct/2021:10:17:27 +0000] “GET /status HTTP/1.1” 200 266 “-” “node-fetch/1.0 (+https://github.com/bitinn/node-fetch)”
I suppose this has to do with some kind of internal monitoring to ensure stability or such, but on tiny vServers like mine regular requests such as those can have a measurable impact on performance. I would like to have a feature, if possible, to disable these regular requests for the reasons stated above.

I already tried:

I had a quick look in the configuration documentation but was unable to find any hints on how to stop this behaviour. If this was due to my inability to properly investigate, don’t hesitate to let me know :smiley:

Hello @kurzdev

if you run the Hedgedoc container, it should be the healthcheck from inside the image.

Greetings
Sheogorath

Hey, cheers.
Do you think it would be possible to maybe crank down (or rather up) the update intervals? Over at vaultwarden, they use 60s intervals with 10s timeouts and it works just fine as well:

Best
kurzdev